summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-26 10:14:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-26 10:16:06 +0100
commitf15ca337bec89f238b9b9ced08c2e02c35629a33 (patch)
treef2561333a9f99339e64e039909fd971f568c1e13
parent078f5bfae7ee174177791defcfd350117a503a6d (diff)
downloadguix-f15ca337bec89f238b9b9ced08c2e02c35629a33.tar.gz
gnu: nyacc: Install all modules.
* gnu/packages/mes.scm (nyacc)[arguments]: Add build phase
'install-system-module.
[propagated-inputs]: Add guile-bytestructures.
-rw-r--r--gnu/packages/mes.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index 5115374514..8ced184a5f 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2017, 2018, 2019, 2020, 2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
 ;;;
@@ -120,8 +120,13 @@ $prefix/share/guile/site/$GUILE_EFFECTIVE_VERSION\n")))))
            (lambda _
              (substitute* "module/nyacc/lang/c99/parser.scm"
                (("\\(memq \\(car stmt\\) '\\(include include-next\\)\\)")
-                "(memq (car stmt) '(include include-next define))")))))))
+                "(memq (car stmt) '(include include-next define))"))))
+         (add-after 'unpack 'install-system-module
+           (lambda _
+             (substitute* "module/Makefile.in"
+               (("@NYACC_FH_BINS@") "$(NYACC_FH_BINS)")))))))
     (inputs (list guile-3.0))
+    (propagated-inputs (list guile-bytestructures))
     (description
      "@acronym{NYACC, Not Yet Another Compiler Compiler} is set of Guile modules
 for generating parsers and lexical analyzers.  It provides sample parsers,