summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-05 04:11:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:02 +0200
commitf2e3d0a947057feee6de3ba866dc72859fd9b9cc (patch)
tree19a2b17b916c4f2888ef9910a9d925dadd742c1d
parent11df832143c64e95b4a28d9f202856c12dfdd424 (diff)
downloadguix-f2e3d0a947057feee6de3ba866dc72859fd9b9cc.tar.gz
gnu: emacs-popup: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-popup)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6dcae16f4d..62c06e8e0e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3290,15 +3290,15 @@ for compilation, debugging, documentation lookup, and so on.")
   (package
     (name "emacs-popup")
     (version "0.5.3")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/auto-complete/popup-el/archive/v"
-                    version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1yrgfj8y69xmcb6kwgplhq68ndm9410qwh7sd2knnd1gchpphdc0"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/auto-complete/popup-el.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1y538siabcf1n00wr4iz5gbxfndw661kx2mn9w1g4lg7yi4n0h0h"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/auto-complete/popup-el")
     (synopsis "Visual Popup User Interface for Emacs")