summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-16 22:53:48 +0100
committerMarius Bakke <marius@gnu.org>2022-02-16 23:02:05 +0100
commitf37eb24df5ecb3a14bd42507076854cc979ddecf (patch)
tree6cd81a0f570242361b7dfc33e49765903085166d
parent3cfd097ea3051847c8260ad41199f0431ab24834 (diff)
downloadguix-f37eb24df5ecb3a14bd42507076854cc979ddecf.tar.gz
gnu: python-cmarkgfm: Don't depend on a specific CFFI version.
Fixes <https://bugs.gnu.org/53883>.
Reported by Dr. Arne Babenhauserheide <arne_bab@web.de>.

* gnu/packages/markup.scm (python-cmarkgfm)[arguments]: Add phase.
[propagated-inputs]: Change from PYTHON-CFFI-1.15 to PYTHON-CFFI.
-rw-r--r--gnu/packages/markup.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index ce131a5835..0292c02a7f 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -269,6 +269,13 @@ implementation.
     (arguments
      (list #:phases
            #~(modify-phases %standard-phases
+               (add-after 'unpack 'relax-requirements
+                 (lambda _
+                   ;; Don't depend on bleeding-edge CFFI, as it is
+                   ;; apparently only needed for Python >= 3.10.
+                   (substitute* "setup.py"
+                     (("cffi>=1\\.15\\.0")
+                      "cffi>=1.0"))))
                (add-after 'unpack 'copy-cmark-gfm
                  (lambda _
                    ;; This package needs the cmark-gfm source files
@@ -291,7 +298,7 @@ implementation.
                    (when tests? (invoke "pytest" "-vv" "tests")))))))
     (native-inputs (list python-pytest))
     (inputs (list cmark-gfm))
-    (propagated-inputs (list python-cffi-1.15))
+    (propagated-inputs (list python-cffi))
     (home-page "https://github.com/theacodes/cmarkgfm")
     (synopsis "Python bindings for GitHub's fork of cmark")
     (description