summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 16:28:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 17:13:49 +0100
commitf51dcc275e6c4de9b95e7a5d8584a307a259a0db (patch)
tree601c6b1ff62e6afc60f23e559c71b3a9037f91c6
parent658b2b62cb62ebf8b55759d41e82dda4e54706bb (diff)
downloadguix-f51dcc275e6c4de9b95e7a5d8584a307a259a0db.tar.gz
gnu: Add r-dotcall64.
* gnu/packages/cran.scm (r-dotcall64): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9001f07c74..4020ecdf9e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9900,3 +9900,27 @@ features in their own packages.")
 check the state of your variables, and assertions (@code{assert_*} functions)
 to throw errors if they aren't in the right form.")
     (license license:gpl3+)))
+
+(define-public r-dotcall64
+  (package
+    (name "r-dotcall64")
+    (version "1.0-0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "dotCall64" version))
+       (sha256
+        (base32
+         "1b8p7m3w0m7bp977c6jz74xkd611cxg11j49yza59k5fp338scb9"))))
+    (properties `((upstream-name . "dotCall64")))
+    (build-system r-build-system)
+    (native-inputs `(("gfortran" ,gfortran)))
+    (home-page "https://git.math.uzh.ch/reinhard.furrer/dotCall64")
+    (synopsis "Enhanced foreign function interface supporting long vectors")
+    (description
+     "This package provides @code{.C64()}, an enhanced version of @code{.C()}
+and @code{.Fortran()} from the R foreign function interface.  @code{.C64()}
+supports long vectors, arguments of type 64-bit integer, and provides a
+mechanism to avoid unnecessary copies of read-only and write-only arguments.
+This makes it a convenient and fast interface to C/C++ and Fortran code.")
+    (license license:gpl2+)))