summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-23 00:25:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-23 00:25:14 +0300
commitf838fe676b9b45eba0e4298abd720314d9a01b1b (patch)
tree234fb770ade6565bb760799afe8303b5e66df660
parent5a8fa27fe49aa21b353d9d026a99a71a1cc05529 (diff)
downloadguix-f838fe676b9b45eba0e4298abd720314d9a01b1b.tar.gz
gnu: python-shellingham: Run test suite.
* gnu/packages/python-xyz.scm (python-shellingham)[arguments]: Add
custom 'check phase.
[native-inputs]: Add python-pytest, python-pytest-mock.
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7eea5d78cc..c623ce3135 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17723,6 +17723,15 @@ implementation has been adapted, improved, and fixed from Molten.")
        (sha256
         (base32 "0iawv24xx6vhwbhqlxyyg901f8pf6abqyfg0711v1bvlipx83g21"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "python" "-m" "pytest" "-v")))))))
+    (native-inputs
+     (list python-pytest python-pytest-mock))
     (home-page "https://github.com/sarugaku/shellingham")
     (synopsis "Tool to detect surrounding shell")
     (description