summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2013-10-21 18:05:25 -0500
committerAndreas Enge <andreas@enge.fr>2013-10-26 01:23:00 +0200
commitfa58ca4376a696205c9039a2562217d1a418ef36 (patch)
treeeb33430697077ff18b025e8276537d004040a8d3
parentb357faace7564e97b030ae7a9e295f2f84bd458c (diff)
downloadguix-fa58ca4376a696205c9039a2562217d1a418ef36.tar.gz
gnu: Add Pem.
 * gnu/packages/pem.scm: New file.
 * gnu-system.am (GNU_SYSTEM_MODULES): Add it.

Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/pem.scm48
2 files changed, 49 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 4ba110624c..b26fcc9ec1 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -142,6 +142,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/patchelf.scm			\
   gnu/packages/pcre.scm				\
   gnu/packages/pdf.scm				\
+  gnu/packages/pem.scm				\
   gnu/packages/perl.scm				\
   gnu/packages/pkg-config.scm			\
   gnu/packages/plotutils.scm			\
diff --git a/gnu/packages/pem.scm b/gnu/packages/pem.scm
new file mode 100644
index 0000000000..324ed607c7
--- /dev/null
+++ b/gnu/packages/pem.scm
@@ -0,0 +1,48 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages pem)
+  #:use-module (guix packages)
+  #:use-module (guix licenses)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages perl))
+
+(define-public pem
+  (package
+    (name "pem")
+    (version "0.7.9")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/pem/pem-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "03iqcki1lakkck1akdyvljjapgqda3l0rh38id7jhrac9kcxqgg2"))))
+    (build-system gnu-build-system)
+    (inputs `(("perl" ,perl)))
+    (home-page "http://www.gnu.org/software/pem/")
+    (synopsis "Personal expenses manager")
+    (description
+     "GNU Pem is a simple tool for tracking personal income and
+expenses.  It operates from the command line and it stores its data
+in a basic text format in your home directory.  It can easily print
+reports of your spending on different expenses via a basic search
+feature.")
+    (license gpl3+)))