summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-29 15:05:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-29 15:27:20 +0100
commitfaa896862c639a6d8dd8b8c2efe187c72af81d64 (patch)
treed62f76d750fd92174a7f5792cfe774c7cef07631
parent5bed6a31eddc0db153643007b58ec823b0b1ce64 (diff)
downloadguix-faa896862c639a6d8dd8b8c2efe187c72af81d64.tar.gz
gnu: Add r-spatstat-explore.
* gnu/packages/cran.scm (r-spatstat-explore): New variable.
-rw-r--r--gnu/packages/cran.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fea0d73649..b341ab80df 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -29099,6 +29099,46 @@ arrays collapsed in specific extents by summing along the appropriate
 diagonals.  This package allows you to compute the tensor product of arrays.")
     (license license:gpl2+)))
 
+(define-public r-spatstat-explore
+  (package
+    (name "r-spatstat-explore")
+    (version "3.0-5")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "spatstat.explore" version))
+              (sha256
+               (base32
+                "0qn8dmymbnh9vdw0hysijkk2nwz5q69i62smpp8f3wy3z898lhwz"))))
+    (properties `((upstream-name . "spatstat.explore")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-abind
+           r-goftest
+           r-matrix
+           r-nlme
+           r-spatstat-data
+           r-spatstat-geom
+           r-spatstat-random
+           r-spatstat-sparse
+           r-spatstat-utils))
+    (home-page "https://spatstat.org/")
+    (synopsis "Exploratory data analysis for the spatstat family")
+    (description
+     "This package implements functionality for exploratory data
+analysis and nonparametric analysis of spatial data, mainly spatial
+point patterns, in the @code{spatstat} family of packages.  Methods
+include quadrat counts, K-functions and their simulation envelopes,
+nearest neighbour distance and empty space statistics, Fry plots, pair
+correlation function, kernel smoothed intensity, relative risk
+estimation with cross-validated bandwidth selection, mark correlation
+functions, segregation indices, mark dependence diagnostics, and
+kernel estimates of covariate effects.  Formal hypothesis tests of
+random pattern (chi-squared, Kolmogorov-Smirnov, Monte Carlo,
+Diggle-Cressie-Loosmore-Ford, Dao-Genton, two-stage Monte Carlo) and
+tests for covariate effects (Cox-Berman-Waller-Lawson,
+Kolmogorov-Smirnov, ANOVA) are also supported.")
+    (license license:gpl2+)))
+
 (define-public r-spatstat-utils
   (package
     (name "r-spatstat-utils")