summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-04-07 16:48:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-11 15:39:29 +0200
commitfc7f80707872a35794c242da11637c4e3dab7d95 (patch)
tree8b845c79d20ff6565cab94654f45b42176f59da9
parent6145e25afa597a1c3c571df8d1ec0ca69b69125f (diff)
downloadguix-fc7f80707872a35794c242da11637c4e3dab7d95.tar.gz
gnu: Add python-stopit.
* gnu/packages/python-xyz.scm (python-stopit): New variable.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 12f0779ba6..e83eb017f5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11081,6 +11081,25 @@ output.")
     (description "This package contains a list of Python Standard Libraries.")
     (license license:expat)))
 
+(define-public python-stopit
+  (package
+    (name "python-stopit")
+    (version "1.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "stopit" version))
+       (sha256
+        (base32 "0vcrcvky249q4rbgmwf18mwmnypfk8jpn4h6knyjf86r7xc9rwzp"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f)) ;there are none
+    (home-page "https://pypi.python.org/pypi/stopit")
+    (synopsis "Timeout control decorator and context managers")
+    (description
+     "Raise asynchronous exceptions in other threads, control the timeout of
+blocks or callables with two context managers and two decorators.")
+    (license license:expat)))
+
 (define-public python-straight-plugin
   (package
     (name "python-straight-plugin")