summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-19 12:57:59 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-01-15 21:35:06 +0100
commitfe571f37f467205d7700d37b162083a62d7fd153 (patch)
treef34edc4d57d7e40879a0989549122257e4c56377
parent7337062556738c935c417fb83c14bfb9d1dc5c63 (diff)
downloadguix-fe571f37f467205d7700d37b162083a62d7fd153.tar.gz
gnu: Add python-yapsy.
* gnu/packages/python-xyz.scm (python-yapsy): New variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 742b56b56b..c9795bd98d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28358,3 +28358,25 @@ manipulating, converting and writing EXIF data to JPEG, WebP and TIFF files.")
     (description "PyRSS2Gen is the interface to generate RSS 2.0 feeds.
 PyRSS2Gen builds the feed up by using a XML generator.")
     (license license:bsd-3)))
+
+(define-public python-yapsy
+  (package
+    (name "python-yapsy")
+    (version "1.12.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "Yapsy" version))
+        (sha256
+          (base32 "12rznbnswfw0w7qfbvmmffr9r317gl1rqg36nijwzsklkjgks4fq"))))
+    (build-system python-build-system)
+    (home-page "http://yapsy.sourceforge.net")
+    (synopsis "Simple plugin system for Python applications")
+    (description "Yapsy, or Yet Another Plugin SYstem, is a small library
+implementing the core mechanisms needed to build a plugin system into a wider
+application.
+
+The main purpose is to depend only on Python's standard libraries and to
+implement only the basic functionalities needed to detect, load and keep track
+of several plugins.")
+    (license license:bsd-3)))