summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-24 14:19:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-24 14:20:47 +0100
commitff8afea9f7c49039c59301086e49422024205a23 (patch)
tree8bbac90c298b2ba3c17ec939165fdfa25f6687ef
parent239c90f4bfe8ea50e94c6593b0b5d99ced7c583b (diff)
downloadguix-ff8afea9f7c49039c59301086e49422024205a23.tar.gz
gnu: python2-backports-csv: Remove sanity-check phase.
* gnu/packages/python-xyz.scm (python2-backports-csv)[arguments]: Remove
'sanity-check phase.
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 53646653e4..edaca9070e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9612,7 +9612,14 @@ Python 2 and Python 3.")
     (license license:psfl)))
 
 (define-public python2-backports-csv
-  (package-with-python2 python-backports-csv))
+  (package
+    (inherit (package-with-python2 python-backports-csv))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; The sanity-check attempts attempts to import the non-existent
+         ;; module "backports".
+         (delete 'sanity-check))))))
 
 (define-public python2-backports-shutil-get-terminal-size
   (package