summary refs log tree commit diff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-11-04 15:07:10 +0000
committerLudovic Courtès <ludo@gnu.org>2023-12-06 23:50:04 +0100
commit0399d5b6101522901b69b985010736505fdf9354 (patch)
tree9e2abe8a188c34fc27b43bb74d4cf49cc6d4d827
parent8da64e88108bf8620a3da20f028059fda438754d (diff)
downloadguix-0399d5b6101522901b69b985010736505fdf9354.tar.gz
gnu: python-autograd: Update to 1.5.
* gnu/packages/machine-learning.scm (python-autograd): Update to 1.5.
  [build-system]: Use pyproject-build-system.
  [arguments]: Remove custom 'check phase.

Change-Id: Ic76510b94d268d5dba6e9b0e057fcfca125e424f
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/machine-learning.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 38e586232b..c100e0be6e 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1968,9 +1968,9 @@ Covariance Matrix Adaptation Evolution Strategy (CMA-ES) for Python.")
     (license license:expat)))
 
 (define-public python-autograd
-  (let* ((commit "442205dfefe407beffb33550846434baa90c4de7")
+  (let* ((commit "c6d81ce7eede6db801d4e9a92b27ec5d409d0eab")
          (revision "0")
-         (version (git-version "0.0.0" revision commit)))
+         (version (git-version "1.5" revision commit)))
     (package
       (name "python-autograd")
       (home-page "https://github.com/HIPS/autograd")
@@ -1981,19 +1981,14 @@ Covariance Matrix Adaptation Evolution Strategy (CMA-ES) for Python.")
                       (commit commit)))
                 (sha256
                  (base32
-                  "189sv2xb0mwnjawa9z7mrgdglc1miaq93pnck26r28fi1jdwg0z4"))
+                  "04kljgydng42xlg044h6nbzxpban1ivd6jzb8ydkngfq88ppipfk"))
                 (file-name (git-file-name name version))))
       (version version)
-      (build-system python-build-system)
+      (build-system pyproject-build-system)
       (native-inputs
        (list python-nose python-pytest))
       (propagated-inputs
        (list python-future python-numpy))
-      (arguments
-       `(#:phases (modify-phases %standard-phases
-                    (replace 'check
-                      (lambda _
-                        (invoke "py.test" "-v"))))))
       (synopsis "Efficiently computes derivatives of NumPy code")
       (description "Autograd can automatically differentiate native Python and
 NumPy code.  It can handle a large subset of Python's features, including loops,