summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2020-03-02 17:24:41 -0500
committerTimothy Sample <samplet@ngyro.com>2020-03-02 17:32:58 -0500
commit0b870f7915f5da43758753fd088a22033936dc50 (patch)
tree902ad930ff43df6e465dd5cca1ee64f7aca7167a
parent668a519870237d3472e5724089d570458874e5b5 (diff)
downloadguix-0b870f7915f5da43758753fd088a22033936dc50.tar.gz
gnu: commencement: Fix gash and gash-utils version references.
* gnu/packages/commencement.scm (gash-boot): When configuring, use the
version of the Gash package instead the version of Guile!
(gash-utils-boot): Likewise, but for Gash-Utils.
-rw-r--r--gnu/packages/commencement.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index c9be884d6e..cebb4b5a68 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -152,7 +152,7 @@ pure Scheme to Tar and decompression in one easy step.")
          (use-modules (guix build gnu-bootstrap))
          (modify-phases %standard-phases
            (replace 'configure
-             (bootstrap-configure ,(version) "gash" "scripts"))
+             (bootstrap-configure ,(package-version gash) "gash" "scripts"))
            (replace 'build (bootstrap-build "gash"))
            (replace 'install (bootstrap-install "gash" "scripts"))
            (add-after 'install 'install-symlinks
@@ -214,7 +214,8 @@ pure Scheme to Tar and decompression in one easy step.")
                (delete-file "scripts/template.in")
                #t))
            (replace 'configure
-             (bootstrap-configure ,(version) "gash" "scripts"))
+             (bootstrap-configure ,(package-version gash-utils)
+                                  "gash" "scripts"))
            (replace 'build (bootstrap-build "gash"))
            (replace 'install (bootstrap-install "gash" "scripts"))
            ;; XXX: The scripts should add Gash to their load paths and