summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 13:30:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:44 +0200
commit1266982dcf626bc91f4ce24455fd2ebba0460938 (patch)
treec061dd2d73f4b3ca282d95633367527aa57a81c7
parent86c456433b62f3f8d09b47149ec9b99892c7f86f (diff)
downloadguix-1266982dcf626bc91f4ce24455fd2ebba0460938.tar.gz
gnu: Add texlive-multibibliography.
* gnu/packages/tex.scm (texlive-multibibliography): New variable.
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5f1b40ed51..718f826464 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13428,6 +13428,35 @@ bibliography for multiple, but different parts of the document.  Multibib is
 compatible with @code{inlinebib}, @code{natbib}, and @code{koma-script}.")
     (license license:lppl)))
 
+(define-public texlive-multibibliography
+  (package
+    (name "texlive-multibibliography")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/multibibliography/"
+                   "doc/latex/multibibliography/"
+                   "scripts/multibibliography/"
+                   "source/latex/multibibliography/"
+                   "tex/latex/multibibliography/")
+             (base32
+              "10281fv7xfqmdc08pyk9l9280crklsfqwf5cwd5ysbhdz1r0grcm")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:link-scripts #~(list "multibibliography.pl")))
+    (inputs (list perl))
+    (home-page "https://ctan.org/pkg/multibibliography")
+    (synopsis
+     "Multiple versions of a bibliography, with different sort orders")
+    (description
+     "Conventional standards for bibliography styles impose a forced choice
+between index and name/year citations, and corresponding references.  The
+package avoids this choice, by providing alphabetic, sequenced, and even
+chronological orderings of references.  Inline citations, that integrate these
+heterogeneous styles, are also supported (and work with other bibliography
+packages).")
+    (license license:lppl1.3+)))
+
 (define-public texlive-multiobjective
   (package
     (name "texlive-multiobjective")