summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-13 18:11:05 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-21 18:59:30 -0800
commit16c84f9031868e4b92820d5b45b430ff9b6eaa34 (patch)
tree59a348b607a640c24aef02b69c18831b774c65c0
parente08739c3c6d5e1fe7bf5c28a889a50086fb873db (diff)
downloadguix-16c84f9031868e4b92820d5b45b430ff9b6eaa34.tar.gz
gnu: Add python2-execnet.
* gnu/packages/python.scm (python2-execnet): New variable.
-rw-r--r--gnu/packages/python.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5eaaa8c252..690d0a3ab8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6886,7 +6886,17 @@ minimal and fast API targetting the following uses:
 @item write scripts to administer multiple environments
 @end enumerate")
     (home-page "http://codespeak.net/execnet/")
-    (license license:expat)))
+    (license license:expat)
+    (properties `((python2-variant . ,(delay python2-execnet))))))
+
+(define-public python2-execnet
+  (let ((execnet (package-with-python2
+                  (strip-python2-variant python-execnet))))
+    (package
+      (inherit execnet)
+      (native-inputs
+       `(("python2-setuptools" ,python2-setuptools)
+         ,@(package-native-inputs execnet))))))
 
 ;;; The software provided by this package was integrated into pytest 2.8.
 (define-public python-pytest-cache