summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-06 16:33:15 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:16 -0400
commit1a7cc53fc82e715fbd9e0f02112cd5ac210f372f (patch)
tree00cbc546d5b9d75c1efef2d2e98115640e86c345
parent1e1c726cdc6a442b836d39cfbf7bc688f9073abb (diff)
downloadguix-1a7cc53fc82e715fbd9e0f02112cd5ac210f372f.tar.gz
gnu: ruby-gherkin: Rename to ruby-cucumber-gherkin.
To reflect the same change upstream.

* gnu/packages/ruby.scm (ruby-gherkin): Rename to...
(ruby-cucumber-gherkin): ... this.
(ruby-cucumber) [propagated-inputs]: Adjust accordingly.
(ruby-cucumber-core): Likewise (and adjust indentation).
(ruby-gherkin): Define as a deprecated package.
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 13 insertions, 6 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d38d2fed1e..97d280f704 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -84,6 +84,7 @@
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages serialization)
   #:use-module (guix packages)
+  #:use-module (guix deprecation)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix gexp)
@@ -5391,7 +5392,7 @@ for select languages.")
     (build-system ruby-build-system)
     (arguments `(#:tests? #f))          ;no test suite in gem
     (propagated-inputs
-     (list ruby-gherkin))
+     (list ruby-cucumber-gherkin))
     (synopsis "Gherkin test suite analysis tool")
     (description "CukeModeler facilitates modeling a test suite that is
 written in Gherkin (e.g.  Cucumber, SpecFlow, Lettuce, etc.).  It does this by
@@ -8022,9 +8023,9 @@ serialization and deserialization of the protocol buffer messages used in
 Cucumber.")
     (license license:expat)))
 
-(define-public ruby-gherkin
+(define-public ruby-cucumber-gherkin
   (package
-    (name "ruby-gherkin")
+    (name "ruby-cucumber-gherkin")
     (version "26.1.0")
     (source (origin
               (method git-fetch)
@@ -8050,6 +8051,8 @@ It is intended be used by all Cucumber implementations to parse
     (home-page "https://github.com/cucumber/gherkin")
     (license license:expat)))
 
+(define-deprecated ruby-gherkin ruby-cucumber-gherkin)
+
 (define-public ruby-gherkin-ruby
   (package
     (name "ruby-gherkin-ruby")
@@ -8300,11 +8303,11 @@ CI environment from environment variables.")
      (list ruby-builder
            ruby-cucumber-core
            ruby-cucumber-create-meta
+           ruby-cucumber-gherkin
            ruby-cucumber-html-formatter
            ruby-cucumber-messages
            ruby-cucumber-wire
            ruby-diff-lcs
-           ruby-gherkin
            ruby-multi-json
            ruby-multi-test))
     (native-inputs
@@ -8407,10 +8410,14 @@ in already-indented code.")
                                (("'cucumber-tag-expressions',.*")
                                 "'cucumber-tag-expressions', '>=4.1.0'\n")))))))
     (native-inputs
-     (list ruby-rspec ruby-coveralls ruby-rubocop ruby-simplecov
+     (list ruby-rspec
+           ruby-coveralls
+           ruby-rubocop
+           ruby-simplecov
            ruby-unindent))
     (propagated-inputs
-     (list ruby-cucumber-messages ruby-gherkin
+     (list ruby-cucumber-gherkin
+           ruby-cucumber-messages
            ruby-cucumber-tag-expressions))
     (synopsis "Core library for the Cucumber BDD app")
     (description "Cucumber is a tool for running automated tests