summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-06 15:27:22 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:15 -0400
commit1e1c726cdc6a442b836d39cfbf7bc688f9073abb (patch)
tree344e1c470a8efc3c472dd449363cec266260a3d0
parentb3a5f534d508184860b95839f0dd26aa416583ee (diff)
downloadguix-1e1c726cdc6a442b836d39cfbf7bc688f9073abb.tar.gz
gnu: ruby-gherkin: Update to 26.1.0, fixing build.
* gnu/packages/ruby.scm (ruby-gherkin): Update to 26.1.0.
[source]: Adjust URL.
[arguments]: Add a #:phases argument.
[home-page]: Adjust URL.
[native-inputs]: Move ruby-cucumber-messages to...
[propagated-inputs]: ... here.
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8e5eeaaa0a..d38d2fed1e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8025,26 +8025,29 @@ Cucumber.")
 (define-public ruby-gherkin
   (package
     (name "ruby-gherkin")
-    (version "14.0.1")
+    (version "26.1.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/cucumber/gherkin-ruby")
+                    (url "https://github.com/cucumber/gherkin")
                     (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1dwa8632nc6kijv8p257jl64rsjmc0fimlaqvxlkdi2h9n1nympb"))))
+                "1rsannfcg5rqh5a3d3paw10kf6mmqjrgbq3k235px4swbyqysmgn"))))
     (build-system ruby-build-system)
-    (native-inputs
-     (list ruby-cucumber-messages ruby-rspec))
-    (arguments
-     `(#:test-target "spec"))
+    (arguments (list #:test-target "spec"
+                     #:phases #~(modify-phases %standard-phases
+                                  (add-after 'unpack 'chdir
+                                    (lambda _
+                                      (chdir "ruby"))))))
+    (native-inputs (list ruby-rspec))
+    (propagated-inputs (list ruby-cucumber-messages))
     (synopsis "Gherkin parser for Ruby")
     (description "Gherkin is a parser and compiler for the Gherkin language.
 It is intended be used by all Cucumber implementations to parse
 @file{.feature} files.")
-    (home-page "https://github.com/cucumber/gherkin-ruby")
+    (home-page "https://github.com/cucumber/gherkin")
     (license license:expat)))
 
 (define-public ruby-gherkin-ruby