summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-20 15:46:42 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 00:44:03 -0400
commit2444b5170644d8a46f160711b5a13cfbb572a922 (patch)
tree7d49bbad5acf2f547a7d976bbf602646d5860123
parent71b596a928c3f94e0e295cb859ce02dd8944f176 (diff)
downloadguix-2444b5170644d8a46f160711b5a13cfbb572a922.tar.gz
gnu: gupnp-igd: Remove patch-docbook-xml phase.
* gnu/packages/gnome.scm (gupnp-igd) [arguments]: Remove patch-docbook-xml
phase.
[native-inputs]: Add libxml2.
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index dd44fcff75..5cac5cf7e0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -260,14 +260,6 @@
       #:configure-flags #~(list "-Dgtk_doc=true")
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'patch-docbook-xml
-            (lambda* (#:key inputs #:allow-other-keys)
-              (with-directory-excursion "doc"
-                (substitute* "gupnp-igd-docs.xml"
-                  (("http://www.oasis-open.org/docbook/xml/4.1.2/")
-                   (string-append #$(this-package-native-input
-                                     "docbook-xml")
-                                  "/xml/dtd/docbook/"))))))
           (add-before 'check 'set-home
             (lambda _
               ;; A test using GIO expects ~/.config/glib-2.0/settings to be
@@ -286,6 +278,7 @@
            gobject-introspection
            gsettings-desktop-schemas
            gtk-doc/stable
+           libxml2                      ;for XML_CATALOG_FILES
            pkg-config))
     (propagated-inputs
      ;; These libraries are required by the .pc file.