summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-15 14:19:53 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:16 -0500
commit30266441045873a30a9443670c607f955e858505 (patch)
treea368fe6d181ee95fad462cdd8b6a68acfc567e77
parentee394937bc1ccac3a1d68e654cb7904b2b66e972 (diff)
downloadguix-30266441045873a30a9443670c607f955e858505.tar.gz
gnu: util-linux: Globally disable the lsns test.
Justification: the test also failed on the CI for x86_64 and caused an
evaluation to fail.

* gnu/packages/linux.scm (util-linux)[phases]{disable-lsns-test}: Disable
globally.
-rw-r--r--gnu/packages/linux.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 65e7eb9c8b..f65b87c3b6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1907,16 +1907,14 @@ providing the system administrator with some help in common tasks.")
                          (string-append
                           all "\n"
                           "ts_skip \"setarch tests are unreliable under QEMU\"")))))
-                  ,@(if (target-x86-32?)
-                        `((add-before 'check 'disable-lsns-test
-                            (lambda _
-                              ;; The lsns tests can fail due to ioctl(_, NS_GET_USERNS)
-                              ;; returning ENOTTY, indicating this kernel does not
-                              ;; support user namespaces.  Curiously, this test can fail
-                              ;; on i686 even if the same test passes on x86_64 on the
-                              ;; same machine.  See <https://issues.guix.gnu.org/49933>.
-                              (delete-file "tests/ts/lsns/ioctl_ns"))))
-                        '())
+                  (add-before 'check 'disable-lsns-test
+                    (lambda _
+                      ;; The lsns tests can fail due to ioctl(_, NS_GET_USERNS)
+                      ;; returning ENOTTY, indicating this kernel does not
+                      ;; support user namespaces.  Curiously, this test can fail
+                      ;; on i686 even if the same test passes on x86_64 on the
+                      ;; same machine.  See <https://issues.guix.gnu.org/49933>.
+                      (delete-file "tests/ts/lsns/ioctl_ns")))
                   (add-after 'install 'move-static-libraries
                     (lambda* (#:key outputs #:allow-other-keys)
                       (let ((lib    (assoc-ref outputs "lib"))