summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 21:36:23 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-12 02:33:55 +0100
commit34920d2adf3b55179b959401f76f7fe093b60377 (patch)
treec41ecae5921685dbbf92b4efa730004bf8e90543
parent2772debc747387744287eed9199fcdbd0345f895 (diff)
downloadguix-34920d2adf3b55179b959401f76f7fe093b60377.tar.gz
gnu: websockify: Don't use unstable tarball.
* gnu/packages/web.scm (websockify)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/web.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index c591ea058a..5f95fa3a23 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -993,13 +993,14 @@ of people.")
     (name "websockify")
     (version "0.8.0")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/novnc/websockify/archive/v"
-                                  version "/archive.tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/novnc/websockify.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1kjq6gibsvbb6zx5gi8hgh7110x62pbwcqkwapf3k7s27w5y907h"))))
+                "0pcic8qs0gdwrfjgfaf893jyddaw97wcjm2mmvwn0xyhmy8mbmw1"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f)) ; FIXME: 2 out of 6 tests fail with "ImportError: No module