summary refs log tree commit diff
diff options
context:
space:
mode:
authorRikard Nordgren <hrn@posteo.net>2023-05-21 17:56:57 +0000
committerjgart <jgart@dismail.de>2023-05-23 08:55:02 -0500
commit36ea29115cd53f63017b61fc4f6633bb5e1d7542 (patch)
tree91fc47883fddc1133650200b56a8b4dbebd4e9df
parent6783f558fa2bcbc662e021e1b3bf502c64706177 (diff)
downloadguix-36ea29115cd53f63017b61fc4f6633bb5e1d7542.tar.gz
gnu: Add python-crcmod.
* gnu/packages/python-crypto.scm (python-crcmod): New variable.

Co-authored-by: jgart <jgart@dismail.de>
Signed-off-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/python-crypto.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 7b2ac2db6e..528bfe604a 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -801,6 +801,32 @@ Networking and Cryptography library.  These libraries have a stated goal
 of improving usability, security and speed.")
     (license license:asl2.0)))
 
+(define-public python-crcmod
+  (package
+    (name "python-crcmod")
+    (version "1.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "crcmod" version))
+              (sha256
+               (base32
+                "07k0hgr42vw2j92cln3klxka81f33knd7459cn3d8aszvfh52w6w"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                ;; As per the Unit Testing subsection in the README.
+                (invoke "python" "-m" "crcmod.test")))))))
+    (synopsis "CRC generator for Python")
+    (description "Python module for generating objects that compute the
+Cyclic Redundancy Check.")
+    (home-page "https://crcmod.sourceforge.net/")
+    (license license:expat)))
+
 (define-public python-blurhash
   (package
     (name "python-blurhash")