summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-08 11:38:47 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-08 12:20:50 +0100
commit3af18d785dc2540d8ea1dddcb1d2abb29da4dd1a (patch)
treeb2715159c568346af302adbc00ddee863b68db3e
parent99d3cfe68a049c4c66651fe17a7a7ea4bad79bf0 (diff)
downloadguix-3af18d785dc2540d8ea1dddcb1d2abb29da4dd1a.tar.gz
gnu: ode: Improve package style.
* gnu/packages/game-development.scm (ode)[source]<snippet>: Remove trailing
[arguments]: Use G-expressions.  Remove trailing #T from phase.
-rw-r--r--gnu/packages/game-development.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 9f196193ca..54bafdc847 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2401,18 +2401,17 @@ a.k.a. XenoCollide) as described in Game Programming Gems 7.")
        (modules '((guix build utils)))
        (snippet
         '(begin
-           (delete-file-recursively "libccd")
-           #t))))
+           (delete-file-recursively "libccd")))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags '("-DODE_WITH_LIBCCD_SYSTEM=ON")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'unbundle-libccd
-           (lambda _
-             (substitute* "CMakeLists.txt"
-               (("configure_file\\(libccd/.*") ""))
-             #t)))))
+     (list
+      #:configure-flags #~(list "-DODE_WITH_LIBCCD_SYSTEM=ON")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'unbundle-libccd
+            (lambda _
+              (substitute* "CMakeLists.txt"
+                (("configure_file\\(libccd/.*") "")))))))
     (inputs
      (list glu libccd mesa))
     (home-page "https://www.ode.org/")