summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-31 23:06:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-31 23:06:45 +0200
commit3bf7bdccee02bad983ce83d540d69abc13a17eda (patch)
treebe307cc96e1fc1a1dbaf2c13aa1d7eefc790ebcb
parent58ff4553289a47f1b97b44eddef2e85a113d3652 (diff)
downloadguix-3bf7bdccee02bad983ce83d540d69abc13a17eda.tar.gz
gnu: Add r-milor.
* gnu/packages/bioconductor.scm (r-milor): New variable.
-rw-r--r--gnu/packages/bioconductor.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 2a3776e8b5..b137232966 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8697,6 +8697,54 @@ to identify differentially methylated regions in epigenetic epidemiology
 studies.")
     (license license:artistic2.0)))
 
+(define-public r-milor
+  (package
+    (name "r-milor")
+    (version "1.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "miloR" version))
+              (sha256
+               (base32
+                "1jz9p3grnczx0bpdw6j64x21in8zgm3qy19hmm296har2rx9m5zs"))))
+    (properties `((upstream-name . "miloR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biocgenerics
+           r-biocneighbors
+           r-biocparallel
+           r-biocsingular
+           r-cowplot
+           r-dplyr
+           r-edger
+           r-ggbeeswarm
+           r-ggplot2
+           r-ggraph
+           r-ggrepel
+           r-gtools
+           r-igraph
+           r-irlba
+           r-limma
+           r-matrix
+           r-matrixstats
+           r-patchwork
+           r-rcolorbrewer
+           r-s4vectors
+           r-singlecellexperiment
+           r-stringr
+           r-summarizedexperiment
+           r-tibble
+           r-tidyr))
+    (native-inputs (list r-knitr))
+    (home-page "https://marionilab.github.io/miloR")
+    (synopsis "Differential neighbourhood abundance testing on a graph")
+    (description
+     "Milo performs single-cell differential abundance testing.  Cell states
+are modelled as representative neighbourhoods on a nearest neighbour graph.
+Hypothesis testing is performed using a negative bionomial generalized linear
+model.")
+    (license license:gpl3)))
+
 (define-public r-minfi
   (package
     (name "r-minfi")