summary refs log tree commit diff
diff options
context:
space:
mode:
authorWiktor Żelazny <wz@freeshell.de>2022-06-08 18:54:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-07-01 10:33:00 +0200
commit3cefd8ba5faec61b30a09b0bd6f01074623929ca (patch)
tree11fa22f664c8f4dda62438f8bc8884f5d0eeb72f
parentec23d7caa871471ad9425a21b34e1f9692a524d4 (diff)
downloadguix-3cefd8ba5faec61b30a09b0bd6f01074623929ca.tar.gz
gnu: Add r-spacetime.
* gnu/packages/cran.scm (r-spacetime): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a636d4f990..7cd3fc1d82 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33534,3 +33534,26 @@ analyses.")
      "This package provides MathJax and macros to enable its use within Rd files
 for rendering equations in the HTML help files.")
     (license (list license:asl2.0 license:gpl3))))
+
+(define-public r-spacetime
+  (package
+    (name "r-spacetime")
+    (version "1.2-7")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "spacetime" version))
+              (sha256
+               (base32
+                "0zpaib69dbdvgj36x807ci3m5jkyc0hp2j5722xkwvl1faynjlhf"))))
+    (properties `((upstream-name . "spacetime")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-lattice r-sp r-zoo r-xts r-intervals))
+    (home-page "https://github.com/edzer/spacetime/")
+    (synopsis "Classes and methods for spatio-temporal data")
+    (description
+     "@command{spacetime} provides classes and methods for spatio-temporal
+data, including space-time regular lattices, sparse lattices, irregular data,
+and trajectories; utility functions for plotting data as map sequences (lattice
+or animation) or multiple time series; methods for spatial and temporal
+matching or aggregation, retrieving coordinates, print, summary, etc.")
+    (license license:gpl2+)))