summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-30 02:00:00 +0200
commit492d56b9e07159493b44dcbbad845cfa16ad70cb (patch)
tree866e8d05c21b81e9df52f5b5d6bdf1cb67d9fc7c
parent4ded034a57ffacdd6c7afa73bb58893afd614644 (diff)
downloadguix-492d56b9e07159493b44dcbbad845cfa16ad70cb.tar.gz
gnu: libstrophe: Update to 0.12.3.
* gnu/packages/messaging.scm (libstrophe): Update to 0.12.3.
[arguments]: Don't explicitly return #t from phases.
-rw-r--r--gnu/packages/messaging.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 02b0d10c6e..00d8d29017 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2089,7 +2089,7 @@ is also scriptable and extensible via Guile.")
 (define-public libstrophe
   (package
     (name "libstrophe")
-    (version "0.12.2")
+    (version "0.12.3")
     (source
      (origin
        (method git-fetch)
@@ -2098,7 +2098,7 @@ is also scriptable and extensible via Guile.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1ispq6sf7pq02irrqfga4i1xhrg1pg0f86qvvnix15clm8i1agld"))))
+        (base32 "17wxaqdcwhm34bl31g9fmsgmnsd7znyxcb9dhw9lmaghkql1sf0h"))))
     (build-system gnu-build-system)
     (arguments
      (list #:configure-flags '(list "--disable-static")
@@ -2107,8 +2107,7 @@ is also scriptable and extensible via Guile.")
          (add-after 'unpack 'patch-make
            (lambda _
              (substitute* "Makefile.am"
-               (("'\\^xmpp_'") "'.'"))
-             #t))
+               (("'\\^xmpp_'") "'.'"))))
          (add-after 'install-licence-files 'install-extra-licence-files
            (lambda _
             (let ((license-directory (string-append #$output