summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-12-06 17:08:53 +0100
committerLudovic Courtès <ludo@gnu.org>2023-12-06 23:50:04 +0100
commit4a6cef9d66ff26e96d63f2f1f886b8212154ca00 (patch)
treeeaaacf2952934c0fa5cb16c350e96fcdd037227a
parent8c294e43eb0b0ea61da7c0570872e0908f64c8ed (diff)
downloadguix-4a6cef9d66ff26e96d63f2f1f886b8212154ca00.tar.gz
gnu: glibc-locales@2.37: Mark as hidden.
Fixes <https://issues.guix.gnu.org/67586>.

* gnu/packages/base.scm (glibc-locales/hurd): Wrap in ‘hidden-package’.

Change-Id: If4f4aa1ef66c53ee0bb52eaea533241652e48cca

Reported-by: Nils Landt <nils@landt.email>
Change-Id: I5150f13be9c3b23e7abe408f815c56f498c92ecb
-rw-r--r--gnu/packages/base.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 6b2e96dc9b..ea6fdc3b88 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1529,7 +1529,10 @@ command.")
      glibc)))
 
 (define-public glibc-locales/hurd
-  (make-glibc-locales glibc/hurd))
+  ;; Locales again; hide them because their 'supported-systems' field suggests
+  ;; they're Hurd-only, making them non-installable on GNU/Linux.
+  (hidden-package
+   (make-glibc-locales glibc/hurd)))
 
 (define* (libc-locales-for-target #:optional
                                   (target (or (%current-target-system)