summary refs log tree commit diff
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-05-28 18:32:37 +0300
committerMarius Bakke <mbakke@fastmail.com>2017-06-04 14:18:43 +0200
commit50d586f6df73ed493b5b04636ac3566782491b90 (patch)
treed38d189345ff714135a5c0b5f5cd6311ffa9e02e
parent2c320d5175ad37200974eb3a64637f3a055d233d (diff)
downloadguix-50d586f6df73ed493b5b04636ac3566782491b90.tar.gz
gnu: Add python-sure.
* gnu/packages/python.scm (python-sure, python2-sure): New variables.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7617490bd4..7bad7fd187 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14926,3 +14926,30 @@ Supported metrics are:
 
 (define-public python2-radon
   (package-with-python2 python-radon))
+
+(define-public python-sure
+  (package
+    (name "python-sure")
+    (version "1.4.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sure" version))
+       (sha256
+        (base32
+         "1iyqsy2d6radi88g1qf0lziy5b39h5cpb3g5jiqyb4xi46ig3x1z"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-mock" ,python-mock)
+       ("python-six" ,python-six)))
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (home-page "https://github.com/gabrielfalcao/sure")
+    (synopsis "Automated testing library in python for python")
+    (description
+     "Sure is a python library that leverages a DSL for writing assertions.
+Sure is heavily inspired by @code{RSpec Expectations} and @code{should.js}.")
+    (license license:gpl3+)))
+
+(define-public python2-sure
+  (package-with-python2 python-sure))