summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 17:01:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:40 +0200
commit54236b3207ed23593dfe68f514fe2607b887a5fe (patch)
tree84e39999797e872dd9f293c6982853dc8f71be70
parent784e3f1e547b814a894bc0b52f9e86860c686b25 (diff)
downloadguix-54236b3207ed23593dfe68f514fe2607b887a5fe.tar.gz
gnu: Add texlive-zx-calculus.
* gnu/packages/tex.scm (texlive-zx-calculus): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1cb85ee221..819e6bf0ff 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7036,6 +7036,27 @@ providing lots more features.  Skew and coloured tableaux are easy, and
 pgfkeys-enabled options are provided both at package load and configurably.")
     (license license:lppl1.2+)))
 
+(define-public texlive-zx-calculus
+  (package
+    (name "texlive-zx-calculus")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/zx-calculus/"
+                   "tex/latex/zx-calculus/")
+             (base32
+              "0vs0f1zs0ccmv001a4x2m5qqcwl2gr2jl0z87qvjq17d3b2kzz88")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/zx-calculus")
+    (synopsis "Library to typeset ZX Calculus diagrams")
+    (description
+     "This library allows you to typeset ZX-calculus directly in LaTeX.  It
+comes with many pre-built wire shapes, a highly customizable node style (with
+multiple flavours for putting labels inside or outside nodes), and a debugging
+mode to avoid getting lost in big diagrams.")
+    (license license:expat)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")