summary refs log tree commit diff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-10-02 12:55:51 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-10-04 09:37:25 +0300
commit552fde3b1e86c6f8503d17b8362c96d0a5d1faf6 (patch)
tree9d3beff27c2e2c1f36b940332aaac1df43d2c7bc
parent4992cd7c4e407117ff0c7befdd8e081e4ac0a1f9 (diff)
downloadguix-552fde3b1e86c6f8503d17b8362c96d0a5d1faf6.tar.gz
gnu: grass: Depend on proj instead of proj.4.
* gnu/packages/geo.scm (grass)[inputs]: Replace proj.4 with proj.
[arguments]: Change --with-proj-share.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/geo.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 9d4a1a8955..7394f3e5ac 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1953,7 +1953,7 @@ track your position right from your laptop.")
          ("openblas" ,openblas)
          ("perl" ,perl)
          ("postgresql" ,postgresql)
-         ("proj.4" ,proj.4)
+         ("proj" ,proj)
          ("python" ,python)
          ("python-dateutil" ,python-dateutil)
          ("python-numpy" ,python-numpy)
@@ -2009,7 +2009,7 @@ track your position right from your laptop.")
                        "--with-netcdf"
                        "--with-postgres"
                        (string-append "--with-proj-share="
-                                      (assoc-ref inputs "proj.4")
+                                      (assoc-ref inputs "proj")
                                       "/share/proj")
                        "--with-pthread"
                        "--with-readline"