summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-11-06 12:06:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-11-13 15:01:15 +0100
commit598b911334c43a1cc7d047c386f45f83d36d8aee (patch)
tree7fa58ed89a331824b319a6773ac77e56e47929e0
parent77025bd51139c74d572299f4b7b33e071cd54cd8 (diff)
downloadguix-598b911334c43a1cc7d047c386f45f83d36d8aee.tar.gz
gnu: Add r-bayesknockdown.
* gnu/packages/bioconductor.scm (r-bayesknockdown): New variable.

Change-Id: Icceffc04071efaa8a8b79144005fa7745abc7e1a
-rw-r--r--gnu/packages/bioconductor.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index cf7e1c07ac..d27ccce6c2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -22757,6 +22757,30 @@ Functions are also provided to enable smooth interoperability of multiple
 Python environments in a single R session.")
     (license license:gpl3)))
 
+(define-public r-bayesknockdown
+  (package
+    (name "r-bayesknockdown")
+    (version "1.28.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BayesKnockdown" version))
+       (sha256
+        (base32 "1argd4gfld2yb0vvpgb5k7m6agmi58712f6g5dj4gnb7kg4rp1l8"))))
+    (properties `((upstream-name . "BayesKnockdown")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-biobase))
+    (home-page "https://bioconductor.org/packages/BayesKnockdown")
+    (synopsis "Posterior probabilities for edges from knockdown data")
+    (description
+     "This package provides a simple, fast Bayesian method for computing
+posterior probabilities for relationships between a single predictor variable
+and multiple potential outcome variables, incorporating prior probabilities of
+relationships.  In the context of knockdown experiments, the predictor
+variable is the knocked-down gene, while the other genes are potential
+targets.  It can also be used for differential expression/2-class data.")
+    (license license:gpl3)))
+
 (define-public r-biocthis
   (package
     (name "r-biocthis")