summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 16:49:27 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 19:02:06 +0100
commit602fbad1e72dc13985335b7070e777cc08511984 (patch)
tree206d8fbc3bf0bcbfc4bc3ff298445917d0088841
parentfbf41223604a5c29ff08cbe9738bc8c51286cf30 (diff)
downloadguix-602fbad1e72dc13985335b7070e777cc08511984.tar.gz
gnu: chez-scheme: Don't use unstable tarball.
* gnu/packages/chez.scm (chez-scheme)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/chez.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index d8c914804e..1e3c4d652c 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -65,12 +65,13 @@
     (version "9.5")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/cisco/ChezScheme/archive/"
-                           "v" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/cisco/ChezScheme.git")
+             (commit (string-append "v" version))))
        (sha256
-        (base32 "135991hspq0grf26pvl2lkwhp92yz204h6rgiwyym0x6v0xzknd1"))
-       (file-name (string-append "chez-scheme-" version ".tar.gz"))
+        (base32 "132fal5hwiq0bqzvfhjsqr4d11cfdh1670f6286ks29xxj1c04zq"))
+       (file-name (git-file-name name version))
        (modules '((guix build utils)))
        (snippet
         ;; Fix compilation with glibc >= 2.26, which removed xlocale.h.