summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-10 10:24:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-12-10 10:24:45 +0200
commit63e06f30ce20fa846a7e2e814976fefcd9eda7d3 (patch)
treed5bf2f4d64ea7e1dd2f6db7e1456611c2472a08a
parent9c30fb27a42bf10a733ef5165df7869588f0b27c (diff)
downloadguix-63e06f30ce20fa846a7e2e814976fefcd9eda7d3.tar.gz
gnu: ubuntu-keyring: Update to 2023.11.28.1.
* gnu/packages/debian.scm (ubuntu-keyring): Update to 2023.11.28.1.
[native-inputs]: Remove gzip; add xz.

Change-Id: Id90acc7a58085321ac96b6ab520f54b20911a8c1
-rw-r--r--gnu/packages/debian.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index 728f2cc845..b0a0b9e5d3 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -149,15 +149,15 @@ contains the archive keys used for that.")
 (define-public ubuntu-keyring
   (package
     (name "ubuntu-keyring")
-    (version "2021.03.26")
+    (version "2023.11.28.1")
     (source
       (origin
         (method url-fetch)
         (uri (string-append "https://launchpad.net/ubuntu/+archive/primary/"
-                            "+files/" name "_" version ".tar.gz"))
+                            "+files/" name "_" version ".tar.xz"))
         (sha256
          (base32
-          "1ccvwh4s51viyhcg8gh189jmvbrhc5wv1bbp4minz3200rffsbj9"))))
+          "0bmafky67hrb79baaydmw7al21lz0wgi4ks5dqfkfqamw5d4bkdf"))))
     (build-system trivial-build-system)
     (arguments
      `(#:modules ((guix build utils))
@@ -167,7 +167,7 @@ contains the archive keys used for that.")
                           (apt (string-append out "/etc/apt/trusted.gpg.d/"))
                           (key (string-append out "/share/keyrings/")))
                      (setenv "PATH" (string-append
-                                      (assoc-ref %build-inputs "gzip") "/bin:"
+                                      (assoc-ref %build-inputs "xz") "/bin:"
                                       (assoc-ref %build-inputs "tar") "/bin"))
                      (invoke "tar" "xvf" (assoc-ref %build-inputs "source"))
                      (for-each (lambda (file)
@@ -175,10 +175,9 @@ contains the archive keys used for that.")
                                (find-files "." "ubuntu-[^am].*\\.gpg$"))
                      (for-each (lambda (file)
                                  (install-file file key))
-                               (find-files "." "ubuntu-[am].*\\.gpg$")))
-                   #t)))
+                               (find-files "." "ubuntu-[am].*\\.gpg$"))))))
     (native-inputs
-     (list tar gzip))
+     (list tar xz))
     (home-page "https://launchpad.net/ubuntu/+source/ubuntu-keyring")
     (synopsis "GnuPG keys of the Ubuntu archive")
     (description