summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-10-19 21:22:37 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-22 13:50:50 +0200
commit64b342ab321ddc513464bfcff39357306f32efc7 (patch)
treec5b2f6b7435731872279db236559ce4f1b627a3a
parentd49d21654a05316670d46d7586caa6c1565019ee (diff)
downloadguix-64b342ab321ddc513464bfcff39357306f32efc7.tar.gz
gnu: Add pytest-7.1.
* gnu/packages/check.scm (python-pytest-7.1): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/check.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 9768e5f8a4..3d320e9c70 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -39,6 +39,7 @@
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 David Elsing <david.elsing@posteo.net>
+;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1093,6 +1094,28 @@ and many external plugins.")
 
 (define-public python-pytest-6 python-pytest)
 
+;; Astropy started using hard dependencies for Pytest 7+, which might
+;; happen for some other projects. It could be set as default in staging.
+(define-public python-pytest-7.1
+  (package
+    (inherit python-pytest)
+    (version "7.1.3")
+    (name "python-pytest")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest" version))
+       (sha256
+        (base32
+         "0f8c31v5r2kgjixvy267n0nhc4xsy65g3n9lz1i1377z5pn5ydjg"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments python-pytest)
+      ((#:phases phases #~%standard-phases)
+        #~(modify-phases #$phases
+            (add-before 'build 'pretend-version
+              (lambda _
+                (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))))))))
+
 (define-public python-pytest-bootstrap
   (package
     (inherit python-pytest)