summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-12-09 01:01:43 -0500
committerHilton Chain <hako@ultrarare.space>2023-12-11 11:18:21 +0800
commit65334547674bdaeb75eb37ffbe23ba6f9fd486b1 (patch)
tree3b5d6ad9864944d0e4ab7f8f1db46023971de759
parenta90bc8b6a82e094b10488030532cf4cd690ce57e (diff)
downloadguix-65334547674bdaeb75eb37ffbe23ba6f9fd486b1.tar.gz
gnu: linux-libre 6.1: Update to 6.1.66.
This release contains fix for an Ext4 data corruption bug introduced in 6.1.64:

https://lore.kernel.org/all/20231205122122.dfhhoaswsfscuhc3@quack3/T/#t
https://lwn.net/Articles/954285/

Only 6.1.64 and 6.1.65 are affected kernel releases:

https://lists.gnu.org/archive/html/guix-devel/2023-12/msg00082.html

* gnu/packages/linux.scm (linux-libre-6.1-version): Update to 6.1.66.
(linux-libre-6.1-pristine-source): Update hash.

Change-Id: I788e4e6bd49607bc7301d8dd780ebebd7c213313
Signed-off-by: Hilton Chain <hako@ultrarare.space>
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fde752a47a..159e83d4d8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -526,7 +526,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
 ;; The "longterm" kernels — the older releases with long-term upstream support.
 ;; Here are the support timelines:
 ;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-6.1-version "6.1.64")
+(define-public linux-libre-6.1-version "6.1.66")
 (define-public linux-libre-6.1-gnu-revision "gnu")
 (define deblob-scripts-6.1
   (linux-libre-deblob-scripts
@@ -536,7 +536,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
    (base32 "1hdibv43xbn1lv83i6qjgfmf1bvqxvq17fryfsq4r4sjgs9212js")))
 (define-public linux-libre-6.1-pristine-source
   (let ((version linux-libre-6.1-version)
-        (hash (base32 "1ry7dp39010hfja1wial6r6q6ilgygwm7gdz22bg4rzaycwam7b2")))
+        (hash (base32 "030sxwzqlf9jg57j1hvd46ffkc9yfplbk3b81faycfa2dk6n57j1")))
    (make-linux-libre-source version
                             (%upstream-linux-source version hash)
                             deblob-scripts-6.1)))