summary refs log tree commit diff
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2021-07-06 00:30:32 -0700
committerEfraim Flashner <efraim@flashner.co.il>2021-12-07 15:25:54 +0200
commit68d15fcf20feddb72f5c2d2ff7d754dcc4f409df (patch)
treecfa7e273960b313211794f2f534f2e6e26b8a915
parent51bf893e53c5097f35a440eafc38c0728d6bc38a (diff)
downloadguix-68d15fcf20feddb72f5c2d2ff7d754dcc4f409df.tar.gz
gnu: make-gccgo: Override empty GOROOT/GCCGOTOOLDIR
gnu/packages/gcc.scm (make-gccgo)[arguments]: Set tool paths
(GOROOT and GCCGOTOOLDIR) even if they are already set to "".

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/gcc.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 493ff2659f..e7807a4797 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -871,9 +871,9 @@ provides the GNU compiler for the Go programming language.")
                         (tooldir (dirname (car (find-files exedir "^cgo$")))))
                    (wrap-program (string-append out "/bin/go")
                      `("GCCGOTOOLDIR" =
-                       (,(string-append "${GCCGOTOOLDIR-" tooldir "}")))
+                       (,(string-append "${GCCGOTOOLDIR:-" tooldir "}")))
                      `("GOROOT" =
-                       (,(string-append "${GOROOT-" out "}")))))))
+                       (,(string-append "${GOROOT:-" out "}")))))))
              (add-before 'configure 'fix-gotools-runpath
                (lambda _
                  (substitute* "gotools/Makefile.in"