summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-03 11:15:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:33 -0500
commit6d7a0b84e202ee29336cc758bf0cb90d5ffcdfb6 (patch)
tree5f84fc4995b12f68a090ed443ae6f5f4e800e590
parent874188c0ab2955412519dc917402fefc6dd723fc (diff)
downloadguix-6d7a0b84e202ee29336cc758bf0cb90d5ffcdfb6.tar.gz
gnu: glade3: Remove sitecustomize.py workaround.
The issue has since been resolved.

* gnu/packages/gnome.scm (glade3)[phases]{fix-tests}: Delete phase.
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a8280ebfe5..db7b6dff27 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3241,28 +3241,21 @@ API add-ons to make GTK+ widgets OpenGL-capable.")
            (lambda _
              (substitute* "meson_post_install.py"
                (("gtk-update-icon-cache") "true"))))
-         ;; XXX: Remove it once this issue is fixed:
-         ;; https://issues.guix.gnu.org/50105.
-         (add-after 'unpack 'fix-tests
-           (lambda _
-             (substitute* "tests/meson.build"
-               (("\\['modules") "#['modules"))))
          (add-before 'configure 'fix-docbook
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "man/meson.build"
-               (("http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl")
+               (("http://docbook.sourceforge.net/release/xsl/\
+current/manpages/docbook.xsl")
                 (string-append (assoc-ref inputs "docbook-xsl")
                                "/xml/xsl/docbook-xsl-"
                                ,(package-version docbook-xsl)
-                               "/manpages/docbook.xsl")))
-             #t))
+                               "/manpages/docbook.xsl")))))
          (add-before 'check 'pre-check
            (lambda _
              (setenv "HOME" "/tmp")
              ;; Tests require a running X server.
              (system "Xvfb :1 &")
-             (setenv "DISPLAY" ":1")
-             #t)))))
+             (setenv "DISPLAY" ":1"))))))
     (inputs
      `(("gtk+" ,gtk+)
        ("libxml2" ,libxml2)))