summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-12-14 21:40:44 -0300
committerVinicius Monego <monego@posteo.net>2023-12-05 16:41:53 -0300
commit6ec6b1c6c1d9e88d3c7fd8c43f23879d67fff750 (patch)
tree93aa085e37e2e1fb3b955f3a471e0ba9400e7e37
parente498147caef72be01d712bf760e53ec1c3dbc6bc (diff)
downloadguix-6ec6b1c6c1d9e88d3c7fd8c43f23879d67fff750.tar.gz
gnu: gerbv: Update to 2.10.0.
* gnu/packages/engineering.scm (gerbv): Update to 2.10.0.
[source]: Switch to maintained repository.
[native-inputs]: Add autoconf, automake, gettext-minimal, libtool.
Remove package labels.
[inputs]: Add comment about GTK+2.  Remove package labels.
[home-page]: Update URL.

Change-Id: Ie30c4ae618b3b57e9b59e3e40f1423fed4d26135
-rw-r--r--gnu/packages/engineering.scm31
1 files changed, 18 insertions, 13 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 9b827aa262..0351967a64 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -860,25 +860,30 @@ and others.")
 (define-public gerbv
   (package
     (name "gerbv")
-    (version "2.7.0")
+    (version "2.10.0")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://sourceforge/gerbv/gerbv/gerbv-"
-                                  version "/gerbv-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/gerbv/gerbv")
+                    (commit (string-append "v" version))))
               (sha256
                (base32
-                "1d2k43k7i4yvbpi4sw1263a8d0q98z2n7aqhmpinpkih8a681vn5"))))
+                "06bcm5zw7whsnnmfld3gl2j907lxc68gnsbzr2pc4w6qc923rgmj"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags '("CFLAGS=-fcommon")))
-    (native-inputs
-     `(("glib:bin" ,glib "bin")         ; for glib-compile-schemas, etc.
-       ("desktop-file-utils" ,desktop-file-utils)
-       ("pkg-config" ,pkg-config)))
-    (inputs
-     `(("cairo" ,cairo)
-       ("gtk" ,gtk+-2)))
-    (home-page "http://gerbv.geda-project.org/")
+    (native-inputs (list autoconf
+                         automake
+                         desktop-file-utils
+                         gettext-minimal
+                         `(,glib "bin")
+                         libtool
+                         pkg-config))
+    (inputs (list cairo
+                  ;; As of 2.10.0 gerbv is still GTK+2 only.  GTK 3/4 porting
+                  ;; issue: https://github.com/gerbv/gerbv/issues/71.
+                  gtk+-2))
+    (home-page "https://gerbv.github.io/")
     (synopsis "Gerber file viewer")
     (description
      "Gerbv is a viewer for files in the Gerber format (RS-274X only), which