summary refs log tree commit diff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-11-04 15:02:39 +0000
committerLudovic Courtès <ludo@gnu.org>2023-12-04 22:26:38 +0100
commit7308129335ea7c8c4e3ce9d6e0adca0b5811087c (patch)
tree18fb09cd05bc2b206527251a72d41c24537b25dc
parentd3ed7bb5e311502d43ccca95ef9032dcde76c911 (diff)
downloadguix-7308129335ea7c8c4e3ce9d6e0adca0b5811087c.tar.gz
gnu: Add python-quadpy.
* gnu/packages/maths.scm (python-quadpy): New variable.

Change-Id: Icb5a60920465bc5861cf32ffe5dc44a9088af890
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/maths.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9363c536c2..72f9f2587a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -137,6 +137,7 @@
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages image-processing)
   #:use-module (gnu packages java)
   #:use-module (gnu packages less)
   #:use-module (gnu packages lisp)
@@ -165,6 +166,7 @@
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-build)
+  #:use-module (gnu packages python-science)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
@@ -3758,6 +3760,40 @@ recurrence schemes.  Furthermore, all functions are fully vectorized and
 can return results in exact arithmetic.")
     (license license:gpl3+)))
 
+(define-public python-quadpy
+  (package
+    (name "python-quadpy")
+    (version "0.16.10")
+    (source
+      (origin
+        (method url-fetch)
+        ; Download zipfile from zenodo, because git checkout is missing
+        ; some data files that are stored via git-lfs.
+        (uri (string-append
+               "https://zenodo.org/records/5541216/files/nschloe/quadpy-v"
+               version
+               ".zip"))
+        (sha256
+          (base32
+            "1f989dipv7lqxvalfrvvlmhlxyl67a87lavyyqrr1mh88glhl592"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+      (list python-importlib-metadata
+            python-numpy
+            python-orthopy
+            python-scipy
+            python-sympy))
+    (native-inputs (list python-accupy python-pytest unzip vtk))
+    (home-page "https://github.com/diego-hayashi/quadpy")
+    (synopsis "Numerical integration, quadrature for various domains")
+    (description
+      "More than 1500 numerical integration schemes for line segments, circles,
+disks, triangles, quadrilaterals, spheres, balls, tetrahedra, hexahedra,
+wedges, pyramids, n-spheres, n-balls, n-cubes, n-simplices, and the
+1D/2D/3D/nD spaces with weight functions exp(-r) and exp(-r2) for fast
+integration of real-, complex-, and vector-valued functions.")
+    (license license:gpl3+)))
+
 (define-public slepc
   (package
     (name "slepc")