summary refs log tree commit diff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-08-21 20:18:37 +0800
committerHilton Chain <hako@ultrarare.space>2023-08-29 22:20:47 +0800
commit77843170f0b7f5189892bd650d127f42151fa591 (patch)
tree409443fc59155422e6491966a0db9d9aa9c8ab5e
parenta9b42ae7eb99b040af12bd49ec0ad8569fe3bfb8 (diff)
downloadguix-77843170f0b7f5189892bd650d127f42151fa591.tar.gz
gnu: Add qogir-icon-theme.
* gnu/packages/gnome-xyz.scm (qogir-icon-theme): New variable.
-rw-r--r--gnu/packages/gnome-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index a1701aaa77..6ba0ee0092 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -240,6 +240,39 @@ simple and consistent.")
 and a few extra features.")
     (license license:gpl3)))
 
+(define-public qogir-icon-theme
+  (package
+    (name "qogir-icon-theme")
+    (version "2023.06.05")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/vinceliuice/Qogir-icon-theme")
+                    (commit (string-replace-substring version "." "-"))))
+              (file-name (git-file-name name version))
+              (modules '((guix build utils)))
+              (snippet '(substitute* "install.sh"
+                          (("gtk-update-icon-cache") "true")))
+              (sha256
+               (base32
+                "1kn8b9zdamxbfbs7b9qpx53hmjw2l40sxpjw93axb1dqy81yc8da"))))
+    (build-system copy-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'install
+                 (lambda _
+                   (let* ((dest (string-append #$output "/share/icons"))
+                          (flags (list "--theme" "all"
+                                       "--color" "all"
+                                       "--dest" dest)))
+                     (mkdir-p dest)
+                     (apply invoke "bash" "install.sh" flags)))))))
+    (home-page "https://www.pling.com/p/1296407/")
+    (synopsis "Flat colorful design icon theme")
+    (description "This package provides a flat colorful design icon theme.")
+    (license license:gpl3)))
+
 (define-public flat-remix-icon-theme
   (package
     (name "flat-remix-icon-theme")