summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-24 18:36:45 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-24 18:43:06 +0100
commit799d4bac62038cf253aacdcfa93fe8f5755fc60f (patch)
treed4616b158305d5e802ce4ce3001f8bdf5903ccca
parent60667159d329b1f07d01b5bd03e3b289208ad406 (diff)
downloadguix-799d4bac62038cf253aacdcfa93fe8f5755fc60f.tar.gz
gnu: python2-futures: Disable tests.
* gnu/packages/python.scm (python2-futures)[arguments]: Set #:test? #f.
-rw-r--r--gnu/packages/python.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 61fcf282ee..a9e5306235 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -261,6 +261,10 @@
                                             ((or "." "..") #f)
                                             (file
                                              (not
+                                              ;; FIXME: Add the 'support' directory
+                                              ;; in the next rebuild cycle, since it
+                                              ;; moved in 2.7.14.  See also
+                                              ;; python2-futures below.
                                               (string-prefix? "test_support."
                                                               file))))))
                        (call-with-output-file "__init__.py" (const #t))
@@ -7766,7 +7770,11 @@ otherwise matches 3.2’s API.")
          (base32
           "1pw1z4329xvlabdpwqa6b7v2fxf7hl64m4cgr22ckbym8m8m4hh5"))))
     (build-system python-build-system)
-    (arguments `(#:python ,python-2))
+    (arguments `(#:python ,python-2
+                 ;; FIXME: Python 2.7.14 moved the test.support library,
+                 ;; but our package has not yet been adjusted.  Enable
+                 ;; tests when the python2 package has been fixed.
+                 #:tests? #f))
     (home-page "https://github.com/agronholm/pythonfutures")
     (synopsis
      "Backport of the concurrent.futures package from Python 3.2")