summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-05 13:40:04 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-12-05 13:43:42 +0200
commit7e795eae155a0fea0739584020fb0945c4d1a1d0 (patch)
tree8c0d88d467d5c37a774ed6b8231c9bc5c9273f2f
parent9d1055c4095cf591db3be7353d1360f3d2da61e2 (diff)
downloadguix-7e795eae155a0fea0739584020fb0945c4d1a1d0.tar.gz
gnu: python-imgviz: Adjust for newer python.
* gnu/packages/image-processing.scm (python-imgviz)[source]: Add snippet
to adjust python module imports.

Change-Id: I50b39fa5acfc766eb9f18658dbfc3053473e0287
-rw-r--r--gnu/packages/image-processing.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 36fee7e276..306da962cc 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -1690,7 +1690,13 @@ purposes.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1bm0wdv5p26i8nl4kx3145cz553v401sgbpgc96sddzjfmfiydcw"))))
+        (base32 "1bm0wdv5p26i8nl4kx3145cz553v401sgbpgc96sddzjfmfiydcw"))
+      (snippet
+       #~(begin (use-modules (guix build utils))
+                (substitute* "imgviz/draw.py"
+                  (("collections\\.Iterable") "collections.abc.Iterable"))
+                (substitute* "imgviz/tile.py"
+                  (("collections\\.Sequence") "collections.abc.Sequence"))))))
     (build-system python-build-system)
     (arguments
      `(#:phases