summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-19 17:24:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-19 17:24:52 +0100
commit80d3150c94a1b33072747a81020f805779530324 (patch)
tree9607c038dee91477945b076e0f498684aa9a19ce
parent8999d2b44c5d26add1a60ea1fc84497b9ad501fd (diff)
downloadguix-80d3150c94a1b33072747a81020f805779530324.tar.gz
gnu: Add ngshmmalign.
* gnu/packages/bioinformatics.scm (ngshmmalign): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4e7e49fecf..a84c1c812c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7825,6 +7825,31 @@ clusters.")
     (home-page "https://sourceforge.net/projects/pardre/")
     (license license:gpl3+)))
 
+(define-public ngshmmalign
+  (package
+    (name "ngshmmalign")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/cbg-ethz/ngshmmalign/"
+                           "releases/download/" version
+                           "/ngshmmalign-" version ".tar.bz2"))
+       (sha256
+        (base32
+         "0jryvlssi2r2ii1dxnx39yk6bh4yqgq010fnxrgfgbaj3ykijlzv"))))
+    (build-system cmake-build-system)
+    (arguments '(#:tests? #false))      ; there are none
+    (inputs
+     `(("boost" ,boost)))
+    (home-page "https://github.com/cbg-ethz/ngshmmalign/")
+    (synopsis "Profile HMM aligner for NGS reads")
+    (description
+     "ngshmmalign is a profile HMM aligner for NGS reads designed particularly
+for small genomes (such as those of RNA viruses like HIV-1 and HCV) that
+experience substantial biological insertions and deletions.")
+    (license license:gpl2+)))
+
 (define-public ruby-bio-kseq
   (package
     (name "ruby-bio-kseq")