summary refs log tree commit diff
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 15:20:39 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-25 21:38:57 +0800
commit84f6a9907b91a1a2fdb5fe3fc4bab177b8734f95 (patch)
tree7bba2d6b8e6d2fb3c9ae4a69231c86ab1cf2a6d1
parent8b1d43a75509366af9ea454ba8bf5b7658eef05c (diff)
downloadguix-84f6a9907b91a1a2fdb5fe3fc4bab177b8734f95.tar.gz
gnu: Add pavucontrol-qt.
* gnu/packages/lxqt.scm (pavucontrol-qt): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/lxqt.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index f1492e022e..7d26e39328 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -846,6 +846,39 @@ respectively.  As such it enables regular users to launch applications with
 permissions of other users including root.")
     (license license:lgpl2.1+)))
 
+(define-public pavucontrol-qt
+  (package
+    (name "pavucontrol-qt")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+                           version "/" name "-" version ".tar.xz"))
+       (sha256
+        (base32 "0pqvhhgw7d00wqw5v3ghm4l8250zy7bqpvhff6l7y1lw0z2fvcp6"))))
+    (build-system cmake-build-system)
+    (inputs
+     `(("glib" ,glib)
+       ("pcre" ,pcre)
+       ("pulseaudio" ,pulseaudio)
+       ("qtbase" ,qtbase)
+       ("qtx11extras" ,qtx11extras)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("lxqt-build-tools" ,lxqt-build-tools)
+       ("qttools" ,qttools)))
+    (arguments
+     '(#:tests? #f                      ; no tests
+       #:configure-flags
+       ;; TODO: prefetch translations files from 'lxqt-l10n'.
+       '("-DPULL_TRANSLATIONS=NO")))
+    (home-page "https://lxqt.org/")
+    (synopsis "Pulseaudio mixer in Qt")
+    (description "@code{pavucontrol-qt} is the Qt port of volume control
+@code{pavucontrol} of sound server @code{PulseAudio}.")
+    (license license:lgpl2.1+)))
+
 (define-public pcmanfm-qt
   (package
     (name "pcmanfm-qt")