summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-05 21:31:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-12-06 08:01:55 +0200
commit8c294e43eb0b0ea61da7c0570872e0908f64c8ed (patch)
tree1cb4d969d576b30f120db75ef6ee38af26e85b35
parent28e98cc0c788b167b75bd824ee2a6bf4f3a49c73 (diff)
downloadguix-8c294e43eb0b0ea61da7c0570872e0908f64c8ed.tar.gz
gnu: qtbase: Skip some more tests on i686-linux.
* gnu/packages/qt.scm (qtbase)[arguments]: Adjust custom 'check phase to
skip 5 more tests on i686-linux.

Change-Id: I2c70fd0dd7e99cc7e039502933981e1b4985e05c
-rw-r--r--gnu/packages/qt.scm29
1 files changed, 26 insertions, 3 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 6595aa96be..d282dfcced 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -863,7 +863,8 @@ developers using C++ or QML, a CSS & JavaScript like language.")
                        "tst_qfiledialog"
                        ;; This test is susceptible to the 600 ms timeout used:
                        "tst_qpauseanimation")
-                      #$@(if (target-ppc64le?)
+                      #$@(cond
+                           ((target-ppc64le?)
                              #~((list
                                  ;; The 'tst_QPainter::fpe_radialGradients'
                                  ;; test fails with a 'Floating point
@@ -881,8 +882,30 @@ developers using C++ or QML, a CSS & JavaScript like language.")
                                  ;; "'Unable to fetch row' || 'database is
                                  ;; locked'" (see:
                                  ;; https://bugreports.qt.io/browse/QTBUG-117114).
-                                 "tst_qsqlthread"))
-                             #~())) "|") ")")))))
+                                 "tst_qsqlthread")))
+                           ((target-x86-32?)
+                             #~((list
+                                 ;; QCOMPARE(qRound(actual), expected) returned TRUE
+                                 ;; unexpectedly.
+                                 "tst_qglobal"
+
+                                 ;; Actual   (llMinDbl == llMin) : 0
+                                 ;; Expected (-9223372036854775807.0 ==
+                                 ;; Q_INT64_C(-9223372036854775807)) : 1
+                                 "tst_json"
+
+                                 ;; 'QVector3D::normal(QVector3D(), v1, v2) ==
+                                 ;; v3.normalized()' returned FALSE. ()
+                                 "tst_qvectornd"
+
+                                 ;; Actual   (qRed(p))  : 11
+                                 ;; Expected (qGreen(p)): 10
+                                 "tst_qcolorspace"
+
+                                 ;; Actual   (dv.validate(value, dummy)): Invalid
+                                 ;; Expected (standard_state)           : Intermediate
+                                 "tst_qdoublevalidator")))
+                           (else #~()))) "|") ")")))))
             (replace 'patch-mkspecs
               (lambda* (#:key outputs #:allow-other-keys)
                 (let* ((archdata (search-input-directory outputs "lib/qt6"))