summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-06-21 23:29:04 -0500
committerChristopher Baines <mail@cbaines.net>2022-06-23 13:00:19 +0100
commit8e2ff622ed7e493a644ebcff62299d2ed1c4e806 (patch)
treedbe52e445be44f8e0160072b068e3e4f08e9262b
parent69bf6319f6326aa79059c0ebca31e7f5bc684bd2 (diff)
downloadguix-8e2ff622ed7e493a644ebcff62299d2ed1c4e806.tar.gz
gnu: python-parso: Update to 0.8.3.
* gnu/packages/yyy.scm (python-parso): Update to 0.8.3.
[arguments]: Satisfy guix lint.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0c3794ed78..84040a2e3f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21413,20 +21413,23 @@ time-based (TOTP) passwords.")
 (define-public python-parso
   (package
     (name "python-parso")
-    (version "0.8.2")
+    (version "0.8.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "parso" version))
        (sha256
-        (base32 "161k8771m7w60qakyvrwf9q62lvakmix7mpfylpy7713qs939f0j"))))
+        (base32 "185gkxq92kqiw2h5zp1cmyn04055x0lix4hmi5c077xm1clvw1wc"))))
     (native-inputs
      (list python-pytest))
     (build-system python-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda _ (invoke "pytest" "-vv"))))))
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" "-vv")))))))
     (home-page "https://github.com/davidhalter/parso")
     (synopsis "Python Parser")
     (description "Parso is a Python parser that supports error recovery and