summary refs log tree commit diff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-01-10 22:25:45 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-11 21:59:06 +1000
commit9656b8bec5730b5da2b4633564b26ff3a1e92d8b (patch)
tree4c6ef7e0ec90b5b7255a6160e8a75849ad22a050
parent761e7042f633b05bee988aeb941d7c7bf20b9b3c (diff)
downloadguix-9656b8bec5730b5da2b4633564b26ff3a1e92d8b.tar.gz
gnu: ruby: Use modify-phases.
* gnu/packages/ruby.scm (ruby)[arguments]: Use modify-phases.
-rw-r--r--gnu/packages/ruby.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1d00835cd7..2fac187fd9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -61,22 +61,22 @@
      `(#:test-target "test"
        #:parallel-tests? #f
        #:phases
-       (alist-cons-before
-        'configure 'replace-bin-sh
-        (lambda _
-          (substitute* '("Makefile.in"
-                         "ext/pty/pty.c"
-                         "io.c"
-                         "lib/mkmf.rb"
-                         "process.c"
-                         "test/rubygems/test_gem_ext_configure_builder.rb"
-                         "test/rdoc/test_rdoc_parser.rb"
-                         "test/ruby/test_rubyoptions.rb"
-                         "test/ruby/test_process.rb"
-                         "test/ruby/test_system.rb"
-                         "tool/rbinstall.rb")
-            (("/bin/sh") (which "sh"))))
-        %standard-phases)))
+       (modify-phases %standard-phases
+         (add-before 'configure 'replace-bin-sh
+           (lambda _
+             (substitute* '("Makefile.in"
+                            "ext/pty/pty.c"
+                            "io.c"
+                            "lib/mkmf.rb"
+                            "process.c"
+                            "test/rubygems/test_gem_ext_configure_builder.rb"
+                            "test/rdoc/test_rdoc_parser.rb"
+                            "test/ruby/test_rubyoptions.rb"
+                            "test/ruby/test_process.rb"
+                            "test/ruby/test_system.rb"
+                            "tool/rbinstall.rb")
+               (("/bin/sh") (which "sh")))
+             #t)))))
     (inputs
      `(("readline" ,readline)
        ("openssl" ,openssl)