summary refs log tree commit diff
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 22:59:56 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:54 +0000
commit9770402a92585f5af15264aacf8718e7f594102c (patch)
tree39c06da54d807fb21cb10ba6b51d05ab3abeef2c
parent8b62d9403ea79ce21d7ef036c4edc3faaa2885bb (diff)
downloadguix-9770402a92585f5af15264aacf8718e7f594102c.tar.gz
gnu: Add ocaml-functoria-runtime
* gnu/packages/ocaml.scm (ocaml-functoria-runtime): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/ocaml.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f6371983d3..38d581682b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3675,6 +3675,39 @@ RFC5321 and RFC6532.  It handles UTF-8 email addresses and encoded-word
 according RFC2047.")
     (license license:expat)))
 
+(define-public ocaml-functoria-runtime
+  (package
+    (name "ocaml-functoria-runtime")
+    (version "4.3.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/mirage/mirage/")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name "mirage" version))
+       (sha256
+        (base32
+         "09mqbffrhnklbc50gaflkwb3h1xysqqiwb84a9q1phjl038pic6r"))))
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "functoria-runtime"
+       ;; TODO
+       ;; again, requires opam for tests, which needs network access.
+       ;; most other tests seem to pass.
+       #:tests? #f))
+    (propagated-inputs
+     (list ocaml-cmdliner ocaml-fmt ocaml-logs ocaml-bos ocaml-ipaddr
+           ocaml-emile ocaml-uri))
+    (native-inputs
+     (list ocaml-alcotest))
+    (home-page "https://github.com/mirage/mirage")
+    (synopsis "Runtime support library for functoria-generated code")
+    (description
+     "This is the runtime support library for code generated by functoria.")
+    (license license:isc)))
+
 (define-public ocaml-ocurl
   (package
     (name "ocaml-ocurl")