summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-10-03 13:03:38 +0000
committerMathieu Othacehe <othacehe@gnu.org>2023-10-06 11:52:13 +0200
commit9930aeb0e3d153fe4d0516aea87a8c28520805e0 (patch)
tree9791ca2a9af36d2563873c93fdede8a51d91c448
parent70c27db33edc76424ac680bd2cb8470573ea42fe (diff)
downloadguix-9930aeb0e3d153fe4d0516aea87a8c28520805e0.tar.gz
gnu: Add python-mapie.
* gnu/packages/statistics.scm (python-mapie): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/statistics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 4c43c144fb..75b91a1dd8 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2296,6 +2296,30 @@ building design matrices.")
     ;; and is covered by the PSFL.
     (license (list license:bsd-2 license:psfl))))
 
+(define-public python-mapie
+  (package
+    (name "python-mapie")
+    (version "0.7.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "MAPIE" version))
+              (sha256
+               (base32
+                "1nvi547avvwrck1n7rf5jh7d0ml6jaqjs2p59iwcq2a5xjmdsmsc"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pandas python-pytest))
+    (propagated-inputs (list python-numpy python-scikit-learn))
+    (home-page "https://github.com/scikit-learn-contrib/MAPIE")
+    (synopsis "Module for estimating prediction intervals")
+    (description "MAPIE allows you to easily estimate prediction intervals
+(or prediction sets) using your favourite scikit-learn-compatible model for
+single-output regression or multi-class classification settings.
+
+Prediction intervals output by MAPIE encompass both aleatoric and epistemic
+uncertainties and are backed by strong theoretical guarantees thanks to
+conformal prediction methods intervals.")
+    (license license:bsd-3)))
+
 (define-public python-statsmodels
   (package
     (name "python-statsmodels")