summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-18 10:39:51 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-18 10:41:46 +0200
commit9b6cddd32dfcffac4cec28366f968cfcce021e1e (patch)
tree27bd17faf447dfc70a382c0f79b29541349ed886
parentc20eee77a13045abcb8a379a12d3c91ed3acce9e (diff)
downloadguix-9b6cddd32dfcffac4cec28366f968cfcce021e1e.tar.gz
gnu: Add ruby-bio-vcf.
* gnu/packages/bioinformatics.scm (ruby-bio-vcf): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c527111928..182e974efc 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7726,6 +7726,31 @@ BLAST, KEGG, GenBank, MEDLINE and GO.")
     ;; (LGPLv2.1+) and scripts in samples (which have GPL2 and GPL2+)
     (license (list license:ruby license:lgpl2.1+ license:gpl2+ ))))
 
+(define-public ruby-bio-vcf
+  (package
+    (name "ruby-bio-vcf")
+    (version "0.9.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (rubygems-uri "bio-vcf" version))
+        (sha256
+         (base32
+          "1glw5pn9s8z13spxk6yyfqaz80n9lga67f33w35nkpq9dwi2vg6g"))))
+    (build-system ruby-build-system)
+    (native-inputs
+     `(("ruby-cucumber" ,ruby-cucumber)))
+    (synopsis "Smart VCF parser DSL")
+    (description
+     "Bio-vcf provides a @acronym{DSL, domain specific language} for processing
+the VCF format.  Record named fields can be queried with regular expressions.
+Bio-vcf is a new generation VCF parser, filter and converter.  Bio-vcf is not
+only very fast for genome-wide (WGS) data, it also comes with a filtering,
+evaluation and rewrite language and can output any type of textual data,
+including VCF header and contents in RDF and JSON.")
+    (home-page "https://github.com/vcflib/bio-vcf")
+    (license license:expat)))
+
 (define-public r-biocviews
   (package
     (name "r-biocviews")