summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2023-08-07 18:15:59 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2023-08-07 18:54:17 +0200
commita4e3b7ce4804681a2086058be50cca556034570b (patch)
treeeaa2544ca5a0bbc4f54abe14737a84652e29c7ae
parentc47f5587a23d6780ad6cae31b56d2d05d446c5c0 (diff)
downloadguix-a4e3b7ce4804681a2086058be50cca556034570b.tar.gz
gnu: Add older version of jbr.
* gnu/packages/java.scm (jbr11): New variable.
-rw-r--r--gnu/packages/java.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 614d585916..1dbec6bd12 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1550,6 +1550,43 @@ blacklisted.certs.pem"
 (define-public openjdk openjdk19)
 
 
+;; This version of JBR is here in order to be able to build custom
+;; IntelliJ plugins.  Those usually need both jbr11 and jbr17 for
+;; tests.
+(define-public jbr11
+  (package
+    (inherit openjdk11)
+    (name "jbr")
+    (version "11_0_16-b2248")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/JetBrains/JetBrainsRuntime.git")
+                     (commit (string-append "jb" version))))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "1fnrdx0wb21ghm6jczjzk7b9fz9hbdzd62512xhwpzvca57v2z09"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments openjdk11)
+       ((#:configure-flags configure-flags)
+        #~(append #$configure-flags
+                  (list "--with-jvm-features=shenandoahgc"
+                        "--enable-cds=yes"
+                        "--with-vendor-name=JetBrains s.r.o"
+                        "--with-vendor-url=https://www.jetbrains.com/"
+                        "--with-vendor-bug-url=https://youtrack.jetbrains.com/issues/JBR")))))
+    (synopsis "JetBrains Java Runtime")
+    (description "This package provides a Java runtime environment for
+and Java development kit.  It supports enhanced class redefinition (DCEVM),
+features optional JCEF, a framework for embedding Chromium-based browsers,
+includes a number of improvements in font rendering, keyboards support,
+windowing/focus subsystems, HiDPI, accessibility, and performance,
+provides better desktop integration and bugfixes not yet present in
+OpenJDK.")
+    (home-page "https://www.jetbrains.com/")
+    (license license:gpl2+)))
+
 (define-public jbr17
   (package
     (inherit openjdk17)