summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-14 16:52:17 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-29 22:59:28 +0100
commita665996f58764a0c6e805016915225f911294989 (patch)
tree0feb3ae24f45bd8e32d592b4e259d09027adbfbd
parentdedc8320701b3f5d23ccc213c1c0381e00b33785 (diff)
downloadguix-a665996f58764a0c6e805016915225f911294989.tar.gz
gnu: python: Set SOURCE_DATE_EPOCH to 1 instead of 0.
* gnu/packages/python.scm (python-2)[arguments]: Set SOURCE_DATE_EPOCH
  to 1 to match what the daemon does.
* guix/build/python-build-system.scm (set-SOURCE-DATE-EPOCH): Likewise.
-rw-r--r--gnu/packages/python.scm2
-rw-r--r--guix/build/python-build-system.scm2
2 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 07725c727a..7f7fa388a1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -164,7 +164,7 @@
              ;; Use zero as the timestamp in .pyc files so that builds are
              ;; deterministic.  TODO: Remove it when this variable is set in
              ;; gnu-build-system.scm.
-             (setenv "SOURCE_DATE_EPOCH" "0")
+             (setenv "SOURCE_DATE_EPOCH" "1")
              #t))
           (add-before
            'check 'pre-check
diff --git a/guix/build/python-build-system.scm b/guix/build/python-build-system.scm
index 6775cc4396..8025b7fec6 100644
--- a/guix/build/python-build-system.scm
+++ b/guix/build/python-build-system.scm
@@ -140,7 +140,7 @@ installed with setuptools."
   "Set the 'SOURCE_DATE_EPOCH' environment variable."
   ;; Use zero as the timestamp in .pyc files so that builds are deterministic.
   ;; TODO: Remove it when this variable is set in GNU:%STANDARD-PHASES.
-  (setenv "SOURCE_DATE_EPOCH" "0"))
+  (setenv "SOURCE_DATE_EPOCH" "1"))
 
 (define %standard-phases
   ;; 'configure' and 'build' phases are not needed.  Everything is done during